Well I have been pounding away on real equipment since I finished building my home lab! I have had my entire rack powered up 24/7 for about a week haha…allows for remote access whenever I need it. Should be an interesting power bill.Â

So, since getting my 28U rack in the mail and my other 2 3550 switches, I have been pounding on IPexpert volume 1 labs (technology specific)Â There are 22 labs in total, each one covering a specific technology.Â

Usually what happens is I read over the lab, and the first time really get my ass kicked hard … I typically have been using the proctor guide quite a bit the first time through to get the concepts down. After I go through and complete the entire lab, I wipe all my configs, and start over…I redo the lab 1 or 2 more times trying not to use the proctor guide at all. The good news is that I see to be doing OK on the 2nd and 3rd runs through. My memory has always been pretty decent…but as Scott Morris says, this is sort of bittersweet…one one hand you are doing well, but on the other hand, you are sort of memorizing the labs. I have made a specific point to really grasp and understand the solutions to each problem, so I am just not spewing out commands from memory.Â

I just finished my 3rd run through of the OSPF lab (lab # 10) and am quite honestly pretty much dreading lab 11 (BGP). I spent a lot of the last 3 or 4 days on this OSPF lab so it breaks my heart to have to write erase all those configs hahaha…

I have to say, there is absolutely NOTHING like having your own equipment and doing this stuff for real. I mean, I have read so much material, but until you actually go in and start doing it, it is not going to really sink in and stick (at least for me). For instance, I had read about route authentication in RIP, EIGRP, and OSPF before a hundred times, but I had never configured it for real. Now that I have actually typed the commands, the process has stuck in my head much more, and I know from experience what to look out for

speaking of startup-configs, I grew tired of trying to copy/paste text file configs into all my devices. Half the time, not all the configuration would get accepted…and I wouldn’t know until half way through the lab when something was broken. So, I’ve actually used some of this crazy CCIE knowledge to do something sort of neat.Â

Basically, I have my home network …. and 20 feet away is my rack. I wanted to connect my home network switch to the lab rack so I could have remote access and also the ability to TFTP configs from my home unix server to the lab, to avoid the copy/paste stuff. So, I have a long ethernet cable going from my home switch to the ethernet interface of the AS. The switch port on the home network is in it’s own little VLAN, which is routed by a 3725 router on a stick.Â

So the issue is that while I had connectivity to the AS, the AS was not in any way networked to the lab equipment from an IP perspective (only with the octal cables for console). All the other ethernet interfaces in the lab environment were used…OK I’ll go from a 3550 port back to the home switch instead…sorry I only have straight thru cables long enough, no crimper or that much inspiration to make my own crossover cable…solution?

Bridging! So now I have home switch –> AS ethernet –> R2 (over serial interface) … then I just bridge on the AS and on R2. Then I have a cat tools script that goes through all my lab devices, erases the configs, and gives them an IP address on the same vlan as the home switch and boom I have connectivity back to the home network to pull configs.

Comments

3 Responses to “Status Update 2008-11-3”

  1. deadheadblues on November 3rd, 2008 7:14 pm

    Hi, I recommend getting a remote power control unit. I got one and it works great – saves money! It has a built in webserver and you can “enable” power on the outlets that way. Look on ebay or google for “ip power 9258”

  2. Roland on November 6th, 2008 3:35 am

    Hi,
    do you have 4×3550 switches? Are they enough for the IPE topology? I’ve bought IPE BLS and I’m thinking about implementing the lab with dynamips routers and real switches and a bunch of usb-to-ethernet adapters. With this lab at home and some rack rental I hope I can study CCIE well.

    Roland

  3. Joe A on November 7th, 2008 12:26 am

    Hi Roland,

    Yes, I do have 4x 3550 switches. For me, they have been really great so far for the IPE material. I have only had 1 issue so far, and I am into volume 1 lab 11. The 1 issue I had was not being able to configure private VLANs in one of the switching labs. Other than that, they can do NEARLY everything a 3560 can do at a fraction of the price.

    I believe the major differences are Private VLANs and some of the QoS features (3560 has a different priority queue and I believe seperate input queues).

    My 3550 switches ran me about $400 each on ebay. To me, if you can do 99% of the material at that price it is worth it, as opposed to spending over a grand a piece on 3560’s to gain that extra 1%.

    Good Luck!

Leave a Reply