I picked up my Mac Mini yesterday from the Apple store. The Apple store scares me and the customers always seem to follow every Apple user stereotype known to man. I waited twenty five minutes just for a sales associate to help me out. I even hit the “Help Me” option on the demo Mac Mini to have an associate come to me. Then I finally get someone over to me and ask about maxing out the memory and they weren’t sure if they could do it in store. Turns out they can, but it will take one of the Mac Genius two hours to do it! Two hours to pop in some laptop dimms. So I come back two hours later to only wait another twenty minutes just for them to get it for me. No one would even look at me to help me. Anyhow….. let me move on from that whole frustrating moment.

I got OS X running smooth, got Dynamips and Dynagen up and running. Made my .net file changes for the new OS and off I went. Well not quite. I could not get Dynagen to bind R1’s Ethernet port to my local Ethernet on the Mac. I searched all over the web for information on my error message: “206-unable to create generic Ethernet NIO”. The few posts pointed to permissions that I found. I was running everything with “sudo” so I was very confused. This was until Scott from Groupstudy was very gracious in helping me out through email. He concluded it was a permission issue and had me run the dynamips command with “sudo -s” first which brought everything up correctly that time. I was able to bridge out from the on board nic to the 3560 just as I could in Vista. I am so used to running as root in Linux I didn’t even think that maybe sudo was not setting enough permissions! Oh well lesson learned there.

Once I have all my USB Ethernet nics I will post how all this has worked out. My wife will kill me if this fails as it did in Vista :). I have a lot on the line with this install!